Print Services for Students


Instructions: Print from Your PC (Linux)

Requirements

  • Linux with Gnome or KDE 5 (older versions of KDE are not supported)
  • Gnome Keyring or KDE Wallet for password storage
  • CUPS, system-config -printer, foomatic-db, foomatic-db-engine

KDE 5 (RPM distribution)  

sudo yum install kf5-kwallet
sudo yum install cups system-config-printer foomatic-db foomatic-db-engine


GNOME (RPM distribution)

sudo yum install gnome-keyring
sudo yum install cups system-config-printer foomatic-db foomatic-db-engine


KDE 5 (DEB distribution)

sudo apt-get install kf5-kwallet
sudo apt-get install cups system-config-printer foomatic-db foomatic-db-engine


Gnome (DEB distribution)

sudo apt-get install libgnome-keyring0
sudo apt-get install cups system-config-printer foomatic-db foomatic-db-engine

Installation

1) Download the package with drivers
2) Open the terminal and become a root

sudo -s


3) Unzip the downloaded package ysoft_safeq_client_for_linux.7z

7z e ysoft_safeq_client_for_linux.7z


4) Install libcrafter_0.0.2_all a ysoft-client_4.x-x_all

dpkg -i libcrafter_0.0.2_all.deb
apt-get -f install
dpkg -i ysoft-client_4.x-x_all.deb
apt-get -f install


for RPM distributions (Fedora, RHEL, etc.) use RPM packages

5) Go to Activities > Print Settings and add a new printer with the Add button

6) Continue with Network Printer > YSoft SafeQ connected printer and Enter device URI

sqport://147.251.19.91/bar_only


7) Select the Generic driver and continue

 

8) Choose PostScript and Generic PostScript printer foomatic

9) Name the driver

10) Restart the computer or the CUPS service

sudo service cups restart


11) After sending a document to print, authorize yourself (UČO + secondary password)

Client Configuration

1) Click Activities > All applications > YSoft SafeQ or type in the terminal

ysoft-client-settings


2) In the Identification field choose Username and password

 

Uninstalling the Client

sudo dpkg -r ysoft-client
sudo dpkg -r libcrafter


The printer will not be removed. You need to delete it in the Print settings.

You are running an old browser version. We recommend updating your browser to its latest version.